Tora Install on Linux Mint 17

We need to start by installing the oracle client appropriate for your architecture. ¬†Grab the oracle instant client rpms from oracle’s site. ¬†Then run…

sudo alien --to-deb oracle-instantclient11.2-*.rpm

Patch

Solution found from a tora bug report.

diff -aur tora-2.1.3/src/toextract.h tora-2.1.3patched/src/toextract.h
--- tora-2.1.3/src/toextract.h	2010-02-02 10:25:43.000000000 -0800
+++ tora-2.1.3patched/src/toextract.h	2012-06-22 21:58:45.026286147 -0700
@@ -53,6 +53,7 @@
 #include 
 //Added by qt3to4:
 #include 
+#include 
 
 class QWidget;
 class toConnection;

Build

svn export https://svn.code.sf.net/p/tora/code/tags/tora-2.1.3
 cd tora-2.1.3
 apt install cmake libboost-system1.55-dev libqscintilla2-dev g++
 cmake -DORACLE_PATH_INCLUDES=/usr/include/oracle/11.2/client64 \
-DCMAKE_BUILD_TYPE=Release -DENABLE_PGSQL=false -DENABLE_DB2=false .
 
 patch -p1 # paste above patch in
 
 make
 sudo tar --strip-components 2 -C /usr/local/bin/ -xzvf tora-2.1.3-Linux.tar.gz

One Reply to “Tora Install on Linux Mint 17”

  1. Linux mint 17.2 update. Do as defined above, but ensure the following packages are installed…

    sudo apt install libqt4-core libqt4-designer libqt4-dev libqt4-gui libqt4-network libqt4-sql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 python-qt4 qt4-qmake qt4-qtconfig
    sudo apt install libqscintilla2-dev

Leave a Reply

Your email address will not be published. Required fields are marked *